Problemas com pacotes no pfSense 2.4.5

Tudo sobre o script PF2AD (http://pf2ad.mundounix.com.br)
Post Reply
lgcosta
Site Admin
Posts: 10
Joined: Sun Sep 17, 2017 1:31 am
Location: Faro, Portugal
Contact:

Problemas com pacotes no pfSense 2.4.5

Post by lgcosta » Mon Apr 26, 2021 9:26 pm

Quando você vai instalar um pacote ou mesmo fazer a implementação do pf2ad, uma série de problemas ocorre no gerenciamento de pacotes do sistema.

Em uma primeira vista, você não consegue instalar nada pela a interface web.

Isso acontece porque foi lançada uma versão mais recente do pfSense, isso faz com que todas as versões anteriores do pfSense fiquem "DEPRECATED", isso é feito de forma automatica assim que eles validam a nova versão.

Veja mais detalhes em: https://docs.netgate.com/pfsense/en/lat ... guide.html

Para corrigir/configurar isto, você deve selecionar em qual arvore de versão você quer manter o sistema, para isso, vá no menu System > Update e no campo Branch, selecione a opção 2.4.5 DEPRECATED

Feito isso, talvez seja necessário corrigir a base de dados do gerenciador de pacotes (pkg), para isso, rode os comandos abaixo:

Code: Select all

/usr/local/sbin/pkg-static update -f
Veja mais detalhes em: https://docs.netgate.com/pfsense/en/lat ... ng-version

Post Reply